UniFi 多 VLAN 环境设置实例

综述

 

本文旨在介绍如何在多楼宇、多楼层的大型局域网中,组建多 VLAN 的有线 & 无线网络及相关设备的主要设置。

 

组网拓扑

 

组网说明

A 座 UniFi 设备管理 VLAN 为 VLAN 101,无线业务 VLAN 为 VLAN 400 和 VLAN 401 ;

B 座 UniFi 设备管理 VLAN 为 VLAN 102,无线业务 VLAN 为 VLAN 500 和 VLAN 501;

UniFi Controller 位于 VLAN 3 中;

A、B 座 UniFi switch 和 AP 通过 DHCP option 43,实现与 UniFi Controller 之间的 L3 adoption。

 

配置说明

核心和汇聚交换机相关配置命令:

核心交换机(Huawei S9300)配置:

vlan 101 A座 UniFi 设备管理 vlan)

vlan 102B座 UniFi 设备管理 vlan)

ip pool 101(pool name)

network 192.168.101.0 mask 255.255.255.0

dns-list 202.102.224.68

gateway-list 192.168.101.1

option 43 hex 0104C0A8030A(L3 adoption详见https://help.ubnt.com/hc/en-us/articles/204909754-UniFi-Layer-3-methods-for-UAP-adoption-and-management#Section_4

 

ip pool 102(pool name)

network 192.168.102.0 mask 255.255.255.0

dns-list 202.102.224.68

gateway-list 192.168.102.1

option 43 hex 0104C0A8030A

 

interface Vlanif 101
ip address 192.168.101.1 24
dhcp select global

 

interface Vlanif 102
ip address 192.168.102.1 24
dhcp select global

 

A座汇聚层交换机(Huawei S5700)配置:

vlan 101

interface GigabitEthernet 1/0/48 (连接 UniFi switch 的端口)
port link-type trunk

port trunk pvid vlan 101
port trunk permit vlan all

 

B座汇聚层交换机(Huawei S5700)配置:

vlan 102

interface GigabitEthernet 1/0/48 (连接 UniFi switch 的端口)
port link-type trunk

port trunk pvid vlan 102
port trunk permit vlan all

UniFI Controller主要配置

保持 Networks > LAN 默认设置

保持 UniFi 交换机 Management VLAN 默认设置

新建 VLAN 400、401、500、501

SSID 映射到对应 VLAN